Errors when attempting to pick up lab reports

Incident Report for Cerbo | Status

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 09:23 PDT

Investigating

We are aware of an error which is keeping lab results from populating in the Lab Results block. We are currently investigating.
Posted Jun 20, 2025 - 09:16 PDT