Connectivity issues with Access Medical Labs

Incident Report for Cerbo | Status

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 11:49 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2025 - 11:46 PST

Identified

Connectivity issues with Access Medical Labs which may impact Imported Lab Results and transmitting orders.
Posted Feb 24, 2025 - 10:12 PST