Quest Order Sending Error: "Quest's servers refused the order"...

Incident Report for Cerbo | Status

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 09:05 PDT

Identified

Quest has confirmed they are experiencing a widespread service disruption and are working to resolve the issue. No ETA is available at this time
Posted Jun 17, 2025 - 08:49 PDT

Investigating

We are currently investigating this issue.
Posted Jun 17, 2025 - 08:29 PDT
This incident affected: Labs (Quest Diagnostics).