We are experiencing a partial outage of lab services.

Incident Report for Cerbo | Status

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 07:58 PDT

Investigating

We are currently investigating this issue.
Posted Jun 27, 2025 - 07:36 PDT