Access Medical Lab service

Incident Report for Cerbo | Status

Resolved

This incident has been resolved and Imported Lab Results and transmitting orders are active.
Posted Feb 21, 2025 - 10:37 PST

Update

We are continuing to work on a fix for this issue.
Posted Feb 21, 2025 - 06:33 PST

Update

Connectivity issues with Access Medical Labs which may impact Imported Lab Results and transmitting orders.
Posted Feb 20, 2025 - 12:57 PST

Identified

We are continuing to work on a fix.
Posted Feb 20, 2025 - 12:57 PST