Unable to process payments via Clover Terminal - New Investigation.

Incident Report for Cerbo | Status

Resolved

This incident has been resolved.
Posted May 14, 2025 - 07:39 PDT

Investigating

Our development team is actively looking into the issues and errors customers are experiencing with the clover terminal. We apologize for the inconvenience and will provide an update soon.
Posted May 12, 2025 - 13:45 PDT