Slowness Reported

Incident Report for Cerbo | Status

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 08:34 PDT

Investigating

We are currently investigating slowness that some Cerbo customers may be experiencing.
Posted Apr 13, 2026 - 08:15 PDT