Unable to send secure messages to patient portal

Incident Report for Cerbo | Status

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 06:32 PDT

Identified

We have identified the issue and will have a fix in place shortly.
Posted Sep 04, 2025 - 05:53 PDT