We are aware of the issue of not being able to process payments via Clover, we are looking into this now.

Incident Report for Cerbo | Status

Resolved

This incident has been resolved.
Posted May 12, 2025 - 07:02 PDT

Investigating

We are currently investigating this issue.
Posted May 09, 2025 - 09:54 PDT